What are the system requirements for the Transparent Language Online mobile app?

The Transparent Language Online mobile app is supported on Android, iOS and Amazon Kindle. System requirements: iPhone/iPod/iPad: iOS 10.0 or later. Android: Android OS 4.0.3 or later. Your data rates may apply. iTunes®, iPhone®, iPod®, and iPad® are trademarks or registered trademarks of Apple Computer, Inc. Android is a trademark of Google Inc. Other product…

What are the system requirements for Transparent Language Online?

Operating System (Computer/Laptop) Windows 7 & higher Mac OS 10.10 & higher Latest version of Chrome OS (Chromebook) Preferred Browser Google Chrome, latest version Supported Browsers Internet Explorer 11 *Internet Explorer requires Flash 11.4 or higher Microsoft Edge, latest version Safari 9 & higher *Safari requires Flash 11.4 or higher Firefox, latest version Operating System…